Jump to content

Recommended Posts

A few weeks ago I started my very first shrimp tank. I started noticing a bunch of small white dandelion looking growths all over the glass and filter of my tank. They're so small you can hardly see them with your eyes unless you're looking very closely. They're attached by a small filiment, and extend into a white parashoot/dandelion fluff that moves in the waters current. There is thousands of them. I redid my tanks substrate (due to having way too much) and decided to take that time to rub it all off. A few days after getting everything set back up, they're back. My amanos and red cherries don't eat it to what I've seen. 

 

I have been to 40+ different forum threads on websites all over the internet, and while some people have the same thing, not a single person has been able to identify what this is. Any help on this subject would be awesome! Below are my tanks parameters, and attached is a very good extremely zoomed in close up of a couple "blooms" of this stuff. The pic is clear but VERY blown up, I can't stress enough how small these things are. Fractions of milimeters. 

 

10 gal tank

Nat Geo LED lighting on for 10ish hours a day

Sponge filter rated for 50gal tank 

 

6.5-7.0 pH

0 ammonia

0 nitrites

10-15 nitrates 

2-3 gH (yes I know this is low for shrimp I'm working to fix)

 

Thank you very much in advance for all your help! I can't seem to find the answer anywhere!!

 

 

 

Screenshot_20181005-145302.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×