Jump to content

Zoo Med 10, anyone?


Recommended Posts

I'm toying with the idea of getting a Zoo Med 10 for my 9 gallon Eheim Aquastyle.

 

I've been using the filter that came with the tank, but it seems like my water has a greenish tint to it.  Plus it has a habit of getting noisy/sounding gluggy.  So, does anyone have experience with this filter, good or bad?

Link to comment
Share on other sites

I have used it on a 6.5 and 8 gallon planted betta and small fish tanks and really liked it.  It's quiet.  I wouldn't use the carbon or bio rings that come with it but it can hold quite a bit of media and as long as you put a sponge on the intake or in the intake filter thing (technical term there :) )  I think it's good. 

Link to comment
Share on other sites

I've got one of these running on an 8g dwarf puffer tank.  I've had no problems with it.   I keep scuds in there so hes got stuff to eat, so I just shoved a lil bit of filter sponge inside the lil square intake guard thing so they don't get sucked in there.

 

 

Quiet and the flow isn't too strong.. but it was a pain in the ass to get it primed and running originally.

Link to comment
Share on other sites

For priming just fill the canister with tank water or dechlorinated water.  I never use that opening at the top to fill but you can.  It will bubble and gurgle for 5 min or so but then it's quiet.  This will happen every time you clean it.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...